Content in WYSIWYG editor not visible on edit in Firefox 11

Charlie Holder's Avatar

Charlie Holder

14 Mar, 2012 01:56 PM

On behalf of Graham at JSU:

We've found an issue with the Firefox 11 update. When you go to edit a page, the text in the WYSIWYG appears for a instant and then disappears. If you look in the HTML view you see it there, but go back to the WYSIWYG and it's still gone. We've found that if you drag the text box of the editor to change it's size the text returns. Not sure what's causing it, but it started today when our browsers updated. Just wanted to pass it along.

  1. Support Staff 2 Posted by Tim on 14 Mar, 2012 02:13 PM

    Tim's Avatar

    Hi Graham,

    So far in my local testing, I've been able to reproduce this on Page assets that have more than 1 WYSIWYG editor. When I edit those Pages, I find that my cursor appears to be invisible in the first WYSIWYG and anything I type does not appear unless I view the HTML source or re-size the editor (as you stated). The 2nd WYSIWYG editor seems to function normally, though.

    Is this consistent with what you are seeing? I'd be interested to know if the Pages you are having problems with have multiple WYSIWYG editors.

    Thanks!

  2. 3 Posted by Graham Lewis on 14 Mar, 2012 02:17 PM

    Graham Lewis's Avatar

    Hey Tim,

    They do have have multiple editors - for for our main content region and one for your "right bar" content region. Here is a video of the error.

    http://www.youtube.com/watch?v=RZ97qc6qUI8&feature=youtu.be

    You are right, the main area is the only one the content disappears from. The 2nd WYSIWYG editor seems to be fine.

  3. Support Staff 4 Posted by Tim on 14 Mar, 2012 02:44 PM

    Tim's Avatar

    Thanks for confirming, Graham. I'm not seeing any javascript errors and I continue to see the behavior after clearing my cache so I'm going to pass this along to my developers to take a look. I'll report back here once I know more.

    Thanks for the report!

  4. 5 Posted by Graham Lewis on 14 Mar, 2012 02:55 PM

    Graham Lewis's Avatar

    Sounds good! Glad I could help!

  5. 6 Posted by bobrien on 19 Mar, 2012 06:17 PM

    bobrien's Avatar

    We are also experiencing this issue, just as it is described above. We also have two WYSIWYG editors. The first one is behaving as described here and the second one works fine. I tried dragging the text box as described, and that also worked as described.

    Do you recommend using another browser in the meantime?

  6. Support Staff 7 Posted by Bradley Wagner on 19 Mar, 2012 06:18 PM

    Bradley Wagner's Avatar

    I would recommend Safari 5, Chrome 13+, Firefox 10 or IE.

  7. 8 Posted by bobrien on 19 Mar, 2012 07:00 PM

    bobrien's Avatar

    Thanks!

  8. 9 Posted by Timothy Gilman on 21 Mar, 2012 11:04 PM

    Timothy Gilman's Avatar

    We are experiencing this as well. If there is no Data Definition on a page, the WYSIWYG works fine. However, in a Data Definition with a multiple WYSIWYGs, only the last one works. (The attached Data Definition is an example where there can be many WYSIWYGs on a page.

    Let me know if you need any additional info.

    Timothy

  9. Support Staff 10 Posted by Bradley Wagner on 22 Mar, 2012 01:29 AM

    Bradley Wagner's Avatar

    Thanks Timothy. We have this problem isolated. It appears to be an issue with any page with multiple WYSIWYGS (which implies a Data Definition as you noted).

    We're tracking a few reports of this:

    Upgrading TinyMCE is not easy at this point as we've made a lot of customizations to the editor. Please hang tight while we look for possible solutions.

    In the interim your options are to downgrade to Firefox 10 or use IE, Chrome, or Safari.

    Sorry for the inconvenience and please watch this discussion for additional updates.

  10. 11 Posted by lmwatson on 22 Mar, 2012 02:40 PM

    lmwatson's Avatar

    We too are having the issue with Firefox 11. My intern found however, if you touch the bottom right corner of the WYSIWYG box and slightly resize it, poof, your content shows.

    I have tried it on several pages and it works for us.

  11. Support Staff 12 Posted by Bradley Wagner on 22 Mar, 2012 02:54 PM

    Bradley Wagner's Avatar

    Sorry, yes, I should have mentioned that above: slightly resizing the WYSIWYG will make the content visible again.

  12. 13 Posted by Timothy Gilman on 22 Mar, 2012 05:40 PM

    Timothy Gilman's Avatar

    Hi Bradley,

    Thanks for the update!

    Timothy

  13. 14 Posted by rreynolds on 22 Mar, 2012 08:29 PM

    rreynolds's Avatar

    We're also experiencing this problem on OSX 10.7.3 Firefox 11. Resizing the window makes the content display.

  14. Support Staff 15 Posted by Bradley Wagner on 29 Mar, 2012 06:45 PM

    Bradley Wagner's Avatar

    A quick update:

    Mozilla has acknowledged this issue and has indicated that it will be fixed in Firefox 12, due out in late April. I verified the fix in their Aurora build of Firefox 12 (will be released in beta on Friday, Mar 30) and it does appear to have corrected the issue.

    I also tested the workarounds suggested on TinyMCE's forums but they do not appear to work in Cascade. I will continue testing workarounds to see if there are any minor changes that we can make to our application's JS files to address this problem in the interim.

    We will also look to upgrade TinyMCE to a later version in Cascade 7.2.

    Again, we're sorry for the inconvenience. Stay tuned here for updates.

  15. Support Staff 16 Posted by Bradley Wagner on 25 Apr, 2012 01:54 PM

    Bradley Wagner's Avatar

    Firefox 12 is now available and fixes the issue with the WYSIWYG content not appearing on load.

  16. Bradley Wagner closed this discussion on 25 Apr, 2012 01:54 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac